Access to personal rooms in Europe not loading
Incident Report for Blindside Networks
Resolved
We identified a problem with delayed responses across Google Cloud regions. We made some updates to the Application and the Deployment to improve performance so the service could be recovered.

The service was fully restored at 16:27 EST on Feb 21, once the changes where rolled out.
Posted Feb 22, 2023 - 14:39 UTC
Investigating
We are seeing errors in the access for personal rooms in Europe and are investigating.
Posted Feb 21, 2023 - 12:38 UTC
This incident affected: Personal Rooms.