We use Amazon for some of our infrastructure and they look like they are experiencing network issues (https://status.aws.amazon.com/). We are adjusting our hosting to compensate for the issues.
Incident Report for Blindside Networks
Resolved
We've adjusted our hosting environment to work around the outage at Amazon. We saw at approximately 2pm ET the launching of all sessions returned to normal.
Posted Oct 09, 2020 - 20:31 UTC
Investigating
We are currently investigating this issue.
Posted Oct 09, 2020 - 15:06 UTC
This incident affected: Servers.