Session in North America are expressing lower performance

Incident Report for Blindside Networks

Resolved

This incident has been resolved. The increase in capacity has decreased the load on the existing servers.
Posted Mar 03, 2023 - 15:03 UTC

Identified

We've identified an issue with provisioning of servers in our North America region. We are increasing our capacity and should have it resolves very soon.
Posted Mar 03, 2023 - 14:08 UTC
This incident affected: Servers.